Strange and scary behavior for delete key

A place for users to ask each other questions, make suggestions, and discuss Bookends.
Post Reply
alanterra
Posts: 76
Joined: Wed Dec 20, 2017 4:55 pm

Strange and scary behavior for delete key

Post by alanterra »

I can't replicate this yet, but I was cleaning up some collections in my Bookends database, and after I deleted a bunch of references from various static collections, suddenly the warning message switched from "Remove N references from group 'Group Name'?" to "Permanently delete N references from the library? This is NOT undo-able."

I noticed this (I hope that I didn't accidentally delete any references) and immediately quit Bookends. I then relaunched the program and all was fine, until it suddenly started happening again. I created a new group, so I could get a good screen grab of the bug, and the bug immediately went away, and now Bookends is acting normally.

If I figure out a recipe for replicating this bug, I'll post it here. But this is just a "head's up" in case someone else (Jon in particular) comes across it.

Read those warning dialogs every time!!!

(No, I haven't tested if Bookends will actually delete the reference under these circumstances -- I can't afford to accidentally lose a reference right now)

A

Bookends 13.2. MacOS 10.14.3.

alanterra
Posts: 76
Joined: Wed Dec 20, 2017 4:55 pm

Re: Strange and scary behavior for delete key

Post by alanterra »

This continues to happen to me. I still don't know if it is a miscreant dialog, or if Bookends would really delete references even though I am selecting them through a static collection (because I am afraid to find out!)

Here is the bug exemplified. I have clicked on the static collection "For BWP", selected every reference, and hit "delete" — and I get this dialog:
Delete from library.jpg
Delete from library.jpg (254.19 KiB) Viewed 543 times
I quit Bookends, relaunch, and repeat the operation, and I get a dialog asking if I want to delete from the collection (as I should)
Delete from collection.jpg
Delete from collection.jpg (100.38 KiB) Viewed 543 times
I still don't know what triggers the bug. It seems to happen after I have had my database open and actively edited for 30 minutes or more.

Post Reply