Page 1 of 1

Can't find file "BOT•File name" for attachments

Posted: Wed Sep 11, 2019 6:52 pm
by acavender
The subject line indicates the chief problem.

I'm running the most recent iPadOS 13 and Catalina betas. Since it's not currently possible to log in to iCloud with Bookends for Mac, I'm using wifi sync.

My Bookends folder exists in iCloud, and it's properly set as the attachment folder in preferences on the Mac. When I sync, the Mac app thinks an attachment is there, but it then complains, in the form indicated in the subject line. It seems that the application is trying to add the "bot" from the path to the file name.

To make the Mac app happy, I have to detach the file, then attach it again. It has no effect on the iPadOS app on sync, other than registering a change in the attachment name, if there was one.

The catch is that I seem to have to do this for each attachment individually. That seems to be the only solution until the final versions of Catalina and iPadOS, but I thought I'd point it out here in case (a) the issue is causing trouble for anyone else and/or (b) the problem isn't just with Apple's betas.

Edited to add: It's possible to save a few steps by selecting "Reattach" instead of detaching then attaching again.

Re: Can't find file "BOT•File name" for attachments

Posted: Wed Sep 11, 2019 8:02 pm
by acavender
New discovery. Reattaching files in the Mac app, then syncing via wifi to the iOS app, does indeed break things. Some of the newly-reattached files sync back to iOS, and some don't.

Re: Can't find file "BOT•File name" for attachments

Posted: Wed Sep 11, 2019 8:11 pm
by acavender
One more new discovery (sorry to have so many posts this evening). Here's what seems to work: reattach files on Mac. Rename files on Mac. Then sync to iOS.

That seems to do the trick.

Re: Can't find file "BOT•File name" for attachments

Posted: Wed Sep 11, 2019 9:37 pm
by acavender
Final post for the night. I think I've got things resolved.

Something may have been messed up on the iPadOS side. I deleted the app, then reinstalled and resynced. All seems okay now.

Re: Can't find file "BOT•File name" for attachments

Posted: Thu Sep 12, 2019 10:33 pm
by acavender
Apparently not. Things are still broken.

When I saw that iCloud sync was working again, I disabled wifi sync, and tried iCloud instead. (Note: I've been using Bookends for iOS as my "canonical" app for reading and annotating PDFs.)

It appeared that sync worked, but none of my annotations came over. When I looked in my Bookends folder in iCloud, I had two files for the article I'd annotated, only one of which contained the new annotations. And because it had a new name, that wasn't the one that synced.

I haven't yet discovered a pattern for why this happens with iOS. I tested on another file, and didn't see the behavior.

I tried starting fresh — I uninstalled and reinstalled Bookends for Mac. I made sure I set the attachments folder to the appropriate folder for iCloud sync. I did that prior to logging into iCloud in Bookends for Mac and syncing.

My references sync just fine. But now I'm right back to "Can't find file 'File name.pdf'" that I saw last night (but without the BOT prefix this time).

The folder is there. The files are there. Bookends is pointed at the folder in preferences. Yet Bookends for Mac steadfastly refuses to see the PDFs that the iOS version sees just fine.

What am I missing?

Re: Can't find file "BOT•File name" for attachments

Posted: Fri Sep 13, 2019 3:46 am
by Serge
BOT prefix is used for Wi-Fi sync only. Mixing both sync methods for the same library on iOS is possible but from your description it looks like there are some problems with attachments... Reinstalling Bookends for iOS for a fresh start was a good decision.

Please try to set Attachments folder location in Bookends for Mac to Factory Default and then to iCloud Folder For iOS Sync again.
If Bookends for Mac still refuses to see the PDF please send me your library and a screenshot of your iCloud Drive folder showing your 'File name.pdf' to

Re: Can't find file "BOT•File name" for attachments

Posted: Sun Sep 15, 2019 6:24 pm
by acavender
Many thanks, Serge.

I appreciate the response.

Though I'm still not sure exactly how things happened, it looks like the primary issue is that file naming somehow got messed up. The Mac version is looking for the wrong file name. If I tell it to reattach the file, then point it to the correct file in the iOS Bookends folder, all is well and things sync. Doing the necessary reattachments will likely be tedious, but should resolve the problem. :D

I am experiencing a lot of crashing on the Mac, but that's likely due to my running the Catalina beta. If it persists, I'll file a report with the crash log via the support form.

Thanks again!